Drupal 5 con PHP 5.3

El gestor de contenidos Drupal en su versión 5 sólo es compatible con las versiones de PHP hasta la 5.2, por lo que los sitios web que continúan usando la versión 5 de Drupal no funcionarán correctamente en los servidores en los que se haya actualizado el PHP a la versión 5.3 o superior.
Como algunos de estos sitios no es posible actualizarlos a la versión 6 de Drupal (o no hay medios para hacerlo) la única forma de hacer que funcionen lo más correctamente posible es aplicando el patch que aparece explicado en este enlace.
Para instalarlo primero tendremos que descargarnos dicho patch, nos situaremos en el directorio raiz en el que tengamos instalado nuestro Drupal 5, y posteriormente lanzaremos el comando:
patch -p1 < <path_al_fichero>/drupal5php53_0.patch
En caso de que al aplicar el patch no se produjeran los efectos esperados, es posible revertir lo realizado con el comando:
patch -p1 -R < <path_al_fichero>/drupal5php53_0.patch
Para más información sobre la forma de aplicar “parches” en Drupal, consultar este enlace.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s