Categorías
GNU/Linux KDE Ubuntu

Jitsi se bloquea en NimbuzzAvatars: cómo arreglarlo

Al instalar Jitsi en un ordenador con Linux KDE Neon 5.18 utilizando las instrucciones de la página de descargas de jitsi.org para Ubuntu/Debian estable, la aplicación no arrancaba, se quedaba la pantalla de inicio bloqueada en el paso NimbuzzAvatars. Para solucionarlo basta con instalar la versión Jitsi del repositorio “inestable”. Para ello modificamos a mano el archivo /etc/apt/sources.list.d/jitsi-stable.list cambiando la palabra stable por unstable y luego renombramos el archivo a /etc/apt/sources.list.d/jitsi-unstable.list para que quede constancia del cambio. También podemos hacerlo con varios comandos:

Borramos el archivo previo:

sudo rm /etc/apt/sources.list.d/jitsi-stable.list

Creamos el nuevo:

sudo sh -c "echo 'deb https://download.jitsi.org unstable/' > /etc/apt/sources.list.d/jitsi-unstable.list"

Desinstalamos el paquete, actualizamos las fuentes e instalamos el paquete de nuevo, que ahora usará la fuente inestable:

sudo apt-get remove jitsi

sudo apt-get -y update

sudo apt-get -y install jitsi

Y con esto ya arranca la aplicación correctamente. Esto debería de funcionar también con cualquier otra distribución basada en Ubuntu 18.04.

Categorías
GNU/Linux OpenSUSE

Instalar Jitsi en OpenSUSE

El servicio de mensajería instantánea Jitsi no está dentro de los repositorios de OpenSUSE, pero es una alternativa interesante a Skype si sólo queremos usar software libre, pues está disponible bajo una licencia LGPL.
Para instalarlo tenemos que descargar el paquete rpm desde la página de descargas de Jitsi. En mi caso me he descargado el paquete jitsi-2.0-latest.x86_64.rpm (para x86_64).

Antes de instalarlo es necesario tener instalado en el sistema el lenguaje Java, en principio podría funcionar tanto con el OpenJDK como con el Java de Oracle. Este último es el que tengo instalado, siguiendo las instrucciones de esta otra entrada.

A continuación lo mejor es instalar el rpm usando Yast mediante el comando:
sudo /sbin/yast -i /home/<nuestro_usuario>/Descargas/jitsi-2.0-latest.x86_64.rpm

Durante la instalación nos dará el error:
nothing provides java >= 1:1.5.0 needed by jitsi-2.0-4506.10553.x86_64
Lo obviamos, indicando al instalador que continúe rompiendo dependencias.
Una vez terminada la instalación, ya podemos usarlo. Permite cuentas de varios proveedores (Google Talk, XMPP, etc.).